Cool Rides Online®
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    May 2011
    Posts
    24
    Achievements & AwardsActivity StatsUser info
    Achievements Kicking the TiresChecking the Gauges
    Awards CRO Member of the Week

    Default My 08 Z is a Lemon

    Its a long story.
    Shot story is I've taken it in Seven time for SES light and TC light. It started in 2010 and it did it today also.
    Liar said I can get total cash value, new car or keep the car and get some cash.

  2. #2
    Junior Member
    Join Date
    May 2011
    Posts
    24
    Achievements & AwardsActivity StatsUser info
    Achievements Kicking the TiresChecking the Gauges
    Awards CRO Member of the Week

    Default

    Got the car back and it seems fine but it seemed fine the last 6 times they worked on it.
    I'm not looking for something for free here I just expect a 70 grand + car to work right.

  3. #3
    Senior Member
    Join Date
    May 2011
    Location
    USA
    Posts
    165
    Achievements & AwardsActivity StatsUser info
    Achievements At the Starting LineBuckling UpKicking the TiresChecking the Gauges

    Default

    Cross your fingers this time. :D

  4. #4
    Hall of Fame Member john mastalerz's Avatar
    Join Date
    Mar 2011
    Location
    Niles,IL
    Posts
    1,341
    Achievements & AwardsActivity StatsUser info
    Achievements At the Starting LineBuckling UpStepping on the GasBurning TiresKicking the Tires
    Awards 104+ Featured Ride - January 2011CRO Ride of the Month Winner - January 2011CRO Member of the Week

    Default

    Quote Originally Posted by Jake08Z06 View Post
    Got the car back and it seems fine but it seemed fine the last 6 times they worked on it.
    I'm not looking for something for free here I just expect a 70 grand + car to work right.
    Are you taking the car back to same shop? Is the same tech always working on it? Maybe try a different shop.

  5. #5
    Resident Dawg & Moderator dawg's Avatar
    Join Date
    Apr 2011
    Location
    Colebrook,CT.
    Posts
    328
    Achievements & AwardsActivity StatsUser info
    Achievements At the Starting LineBuckling UpStepping on the GasKicking the TiresChecking the Gauges
    Awards CRO Member of the Week

    Default

    I fixed a buddies corvette with same issue.
    TC light was a faulty wheel speed sensor.
    (yours is probably dirty)
    SES light was a faulty plug wire.
    best bet is to buy a cheap OBDII reader from advance or autozone and youll be able see exactly what is at fault and be able to erase those codes.
    btw if you live in the rust belt wheel speed sensor issues are commonplace.
    Last edited by dawg; 07-01-2011 at 04:14 PM.
    "As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear God protect my ride." -Amen

    US NAVY RETIRED


Share This Thread!

Facebook Twitter Google Digg Reddit LinkedIn Pinterest StumbleUpon Email

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Enter our Featured Rides Contest Let Us Show Our Support for You Become a CRO Champion!
Single Sign On provided by vBSSO